Опубликовано Оставить комментарий

Формулы количества и суммы в Excel

формулы эксельФормулы количества и суммы в Excel — это самые популярные формулы Эксель, которые чаще всего могут понадобиться для составления различных видов отчетов. При этом может понадобиться выбрать не все значения подряд. Иногда нужны формулы Excel, с помощью которых нужно выбрать и посчитать значения количества и суммы,  удовлетворяющие определенным условиям. Для решения этих задач подходят следующие формулы:

Формулы количества Excel

СЧЁТ

Подсчитывает количество ячеек, содержащих числа
Учитывает аргументы, являющиеся числами, датами или текстовым представлением чисел (например, число, заключенное в кавычки, такое как «1»).

Синтаксис: СЧЁТ(значение1;[значение2];…)
Пример формулы: =СЧЁТ(A1:A20)

СЧЁТЗ

Подсчитывает количество заполненных ячеек в диапазоне.

Учитывает данные любого типа, включая значения ошибок и пустой текст («»). Например, если в диапазоне есть формула, которая возвращает пустую строку, функция СЧЁТЗ учитывает это значение. Функция СЧЁТЗ не учитывает пустые ячейки.

Синтаксис: СЧЁТЗ(значение1;[значение2];…)
Пример формулы: =СЧЁТЗ(A2:A7)

СЧИТАТЬПУСТОТЫ

Подсчитывает пустые ячейки в указанном выше диапазоне.

Синтаксис: СЧИТАТЬПУСТОТЫ(значение1;[значение2];…)
Пример формулы: =СЧИТАТЬПУСТОТЫ(A2:A7)

СЧЁТЕСЛИ

Подсчитывает количество ячеек, отвечающих определенному условию (например, число поставщиков из определенного города). Функция СЧЁТЕСЛИ не учитывает регистр символов.

Синтаксис: =СЧЁТЕСЛИ(где нужно искать; что нужно найти)
Пример формулы: =СЧЁТЕСЛИ(A2:A5;»Лондон»); =СЧЁТЕСЛИ(A2:A5;A4)

СЧЁТЕСЛИМН

Подсчитывает количество ячеек, которые удовлетворяют нескольким условиям. Важно: Каждый дополнительный диапазон должен состоять из такого же количества строк и столбцов, что и аргумент диапазон_условия1. Эти диапазоны могут не находиться рядом друг с другом.

Синтаксис: =СЧЁТЕСЛИМН(диапазон_условия1;условие1;[диапазон_условия2;условие2];…)
Пример формулы: =СЧЁТЕСЛИМН(B2:B5,»=Да»,F2:F5,»>1″)

Формулы суммы Excel

СУММ

Суммирует значения. Вы можете складывать отдельные значения и диапазоны ячеек.

Пример формулы: =СУММ(A2:A10), =СУММ(A2:A10;C2:C10)

СУММЕСЛИ

Суммирует значения, которые соответствуют указанному условию. Можно задать условие для текущего диапазона, а просуммировать соответствующие значения из другого диапазона.
Например, формула =СУММЕСЛИ(B3:B9; «Яблоки»; C3:C9) суммирует только те значения из диапазона C3:C9, для которых соответствующие значения из диапазона B2:B5 равны «Яблоки».

Синтаксис: =СУММЕСЛИ(диапазон; условие;[диапазон_суммирования])
Пример формулы: =СУММЕСЛИ(B2:B25;»> 5″), =СУММЕСЛИ(A2:A7;»Фрукты»;C2:C7)

СУММЕСЛИМН

Суммирует все значения, которые удовлетворяют нескольким условиям. Например, с помощью функции СУММЕСЛИМН можно найти число всех поставщиков, (1) находящихся в определенном городе, (2)которые продают определенный товар.

Синтаксис: СУММЕСЛИМН(диапазон_суммирования; диапазон_условия1; условие1; [диапазон_условия2; условие2]; …)
Пример формулы: =СУММЕСЛИМН(B2:B9; C2:C9; «Рязань»; E2:E9; «Бананы»)

В Excel также есть полезные функции, о которых мало кто знает. Они достаточно простые,  но при этом могут существенно упростить работу и сэкономить время в десятки и сотни раз. Полезные лайфхаки можно прочитать в статье «Полезные функции Excel: мелочи, которые помогут упростить работу«.
Добавить комментарий